Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> * Let's rename them BufFileReadCount and BufFileWriteCount to reflect> their actual purpose.
It looks good. No one uses NDirectFileRead/Write variables now,so we can rename it freely.
BTW, we have the word 'Direct' in ShowBufferUsage().Can I keep it as-is?
ShowBufferUsage()! Shared blocks: ...! Local blocks: ...! Direct blocks: <R> read, <W> written
> * In any case I agree that the current arrangement> with execdebug.h declaring variables defined in bufmgr.c is just weird.
Regards,---ITAGAKI TakahiroNTT Open Source Software Center