| From: | Jacob Champion <jacob(dot)champion(at)enterprisedb(dot)com> |
|---|---|
| To: | "Hayato Kuroda (Fujitsu)" <kuroda(dot)hayato(at)fujitsu(dot)com> |
| Cc: | Fujii Masao <masao(dot)fujii(at)gmail(dot)com>, "pgsql-hackers(at)lists(dot)postgresql(dot)org" <pgsql-hackers(at)lists(dot)postgresql(dot)org> |
| Subject: | Re: [PATCH] Explain what the default output_plugin_libraries do |
| Date: | 2026-09-21 16:01:46 |
| Message-ID: | CAOYmi+nQ=+Ss8G0aOTVc7Ss41iqhsN3_OqnTUYCWKyS9ahyXPw@mail.gmail.com |
| Views: | Whole Thread | Raw Message | Download mbox | Resend email |
| Thread: | |
| Lists: | pgsql-hackers |
On Thu, Sep 17, 2026 at 1:42 AM Hayato Kuroda (Fujitsu)
<kuroda(dot)hayato(at)fujitsu(dot)com> wrote:
> How about attached?
> + An output plugin must be installed as a dynamically loadable library in a
> + location where the server can find it (see <xref linkend="xfunc-c-dynload"/>).
I think we should explicitly recommend installation into the
dynamic_library_path ($libdir for most people). Anything outside of
dynamic_library_path couples clients to the directory layout, and it
makes output_plugin_libraries maintenance harder/uglier.
> > Okay. Any thoughts on Bharath's note on "publication slot creation" above?
>
> I could not find the term "publication slot" in the existing doc, so I prefer
> his idea. Another one I came up with to just simplify:
>
> ```
> Removing from output_plugin_libraries will cause future logical replication to
> fail with an error. (Beware that existing replication tools may not degrade gracefully
> if the server is configured in this way.)
But only built-in logical replication will fail. How about
Core plugin for logical replication. Removing
<literal>pgoutput</literal>
from <literal>output_plugin_libraries</literal> will cause future
subscription connections, and maintenance of the replication slots
for subscriptions, to fail with an error. (Beware that ...
?
Thanks!
--Jacob
| From | Date | Subject | |
|---|---|---|---|
| Next Message | Melanie Plageman | 2026-09-21 16:18:41 | Re: eliminate xl_heap_visible to reduce WAL (and eventually set VM on-access) |
| Previous Message | Alexandre Felipe | 2026-09-21 15:58:50 | Re: Restructured Shared Buffer Hash Table |