Inconsistent error message in bt_page_items_bytea().

From: Ashutosh Sharma <ashu(dot)coek88(at)gmail(dot)com>
To: pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Inconsistent error message in bt_page_items_bytea().
Date: 2018-07-27 11:43:37
Message-ID: CAE9k0PnZuZ3PVXSyQY91-53E8JKFcaSyknFqqU43r9MabKSYZA@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

Hi All,

All the pageinspect functions dealing with raw page has the error
message as "must be superuser to use raw page function" however,
that's not true for bt_page_items_bytea() which has "must be
superuser to use pageinspect functions". This seems to me like a copy
paste error which got transferred from bt_page_items (the function
that doesn't deal with raw page).

Attached is the patch with the correct error message.

--
With Regards,
Ashutosh Sharma
EnterpriseDB:http://www.enterprisedb.com

Attachment Content-Type Size
fix-error-message_bt_page_items_bytea.patch text/x-patch 497 bytes

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Fabien COELHO 2018-07-27 11:53:50 Re: pgbench - very minor bug fix on hash() missing argument
Previous Message Alexander Korotkov 2018-07-27 11:18:28 My Skype account (korotkovae) was hacked