Re: s/xlog/wal/ in tools and function names?

From: Vladimir Rusinov <vrusinov(at)google(dot)com>
To: Michael Paquier <michael(dot)paquier(at)gmail(dot)com>, Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: s/xlog/wal/ in tools and function names?
Date: 2016-12-02 11:28:25
Message-ID: CAE1wr-w=LE1cK5uG_rmAh-VBxc4_Bnw-gAE3qSqL-=tWwvLvjQ@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

On Fri, Dec 2, 2016 at 2:02 AM Michael Paquier <michael(dot)paquier(at)gmail(dot)com>
wrote:

> On Fri, Dec 2, 2016 at 3:21 AM, Robert Haas <robertmhaas(at)gmail(dot)com> wrote:
> > On Thu, Dec 1, 2016 at 10:29 AM, Vladimir Rusinov <vrusinov(at)google(dot)com>
> wrote:
> >> I've found myself wondering "where is my xlog" after running
> >> pg_switch_xlog() in 10.0.
> >>
> >> Renaming pg_xlog to pg_wal created inconsistency between tools, function
> >> names and directory name on disk.
> >>
> >> Should we also:
> >>
> >> - rename pg_switch_xlog and friends to pg_switch_wal?
> >> - rename pg_recievexlog to pg_revievewal (and others in bin/)?
> >> - rename pg_xlogdump to pg_waldump?
> >
> > I think yes to all.
>
> I was hesitant to propose that, but if there is a will do move
> everything...

I'd like to see this happen, and sounds like so far there is a consensus
that it's a good idea.
Since I'm the one who proposed it, I can send out patches for some or maybe
even eventually all of them.

I guess it would make sense to do all of it in 10.0.
I'm new here, so not very sure about process. How many commit fests could I
expect before 10.0 is out (I'm a bit busy at the moment)?

> Documentation would point to different pages if the
> utilities are renamed, so that's not helpful when comparing features
> across major releases... We may want to keep those files with their
> historical names.
>

I'd rather have html redirects set up (assuming they are technically
possible).
In 10.0+ we'll have pg_receivexlog -> pg_receivewal, and we'll need to have
patches adding redirects pg_receivewal -> pg_receivexlog to older branches
so that people can jump between versions easily on the website.

>
> >> - if we do rename, should we keep aliases for functions and symlinks for
> >> tools?
> >
> > I think no.
>
> Better to do breakages in a single release rather than spreading them
> across releases. While at it and because we are on a crazy trend, one
> thing we could as well consider is removing pg_xlog_location_diff().
> It has lost sense since pg_lsn has been introduced.
>
> >> - anything else?
> >
> > There are some SQL-callable functions that should probably be renamed
> > to match, too.
>
> =# select proname from pg_proc where proname ~ 'xlog';
> proname
> ---------------------------------
> pg_current_xlog_location
> pg_current_xlog_insert_location
> pg_current_xlog_flush_location
> pg_xlogfile_name_offset
> pg_xlogfile_name
> pg_xlog_location_diff
> pg_last_xlog_receive_location
> pg_last_xlog_replay_location
> pg_is_xlog_replay_paused
> pg_switch_xlog
> pg_xlog_replay_pause
> pg_xlog_replay_resume
> (12 rows)
> --
> Michael
>

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Haribabu Kommi 2016-12-02 11:55:50 Re: Patch to implement pg_current_logfile() function
Previous Message Fabien COELHO 2016-12-02 10:53:05 Re: pgbench more operators & functions