|From:||Jürgen Purtz <juergen(at)purtz(dot)de>|
|To:||Corey Huinker <corey(dot)huinker(at)gmail(dot)com>|
|Cc:||Justin Pryzby <pryzby(at)telsasoft(dot)com>, Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>, Roger Harkavy <rogerharkavy(at)gmail(dot)com>, pgsql-hackers(at)postgresql(dot)org, Fabien COELHO <coelho(at)cri(dot)ensmp(dot)fr>, Michael Paquier <michael(at)paquier(dot)xyz>|
|Subject:||Re: Add A Glossary|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
On 30.03.20 19:10, Corey Huinker wrote:
> On Sun, Mar 29, 2020 at 5:29 AM Jürgen Purtz <juergen(at)purtz(dot)de
> <mailto:juergen(at)purtz(dot)de>> wrote:
> On 27.03.20 21:12, Justin Pryzby wrote:
> > On Fri, Mar 20, 2020 at 11:32:25PM +0100, Jürgen Purtz wrote:
> >>>> + <glossterm>Archiver</glossterm>
> >>> Can you change that to archiver process ?
> >> I prefer the short term without the addition of 'process' -
> >> 'Archiver' as well as the other cases. But I'm not an native
> >> speaker.
> > I didn't like it due to lack of context.
> > What about "wal archiver" ?
> > It occured to me when I read this.
> "WAL archiver" is ok for me. In the current documentation we have 2
> places with "WAL archiver" and 4 with "archiver"-only
> (high-availability.sgml, monitoring.sgml).
> "backend process" is an exception to the other terms because the
> standalone term "backend" is sensibly used in diverse situations.
> Kind regards, Jürgen
> I've taken Alvarao's fixes and done my best to incorporate the
> feedback into a new patch, which Roger's (tech writer) reviewed yesterday.
> The changes are too numerous to list, but the highlights are:
> New definitions:
> * All four ACID terms
> * Vacuum (split off from Autovacuum)
> * Tablespace
> * WAL Archiver (replaces Archiver)
> Changes to existing terms:
> * Implemented most wording changes recommended by Justin
> * all remaining links were either made into xrefs or edited out of
> * de-tagged most second uses of of a term within a definition
> Did not do
> * Addressed the " Process" suffix suggested by Justin. There isn't
> consensus on these changes, and I'm neutral on the matter
> * change the Cast definition. I think it's important to express
> that a cast has a FROM datatype as well as a TO
> * anything host/server related as I couldn't see a consensus reached
> Other thoughts:
> * Trivial definitions that are just see-other-definition are ok
> with me, as the goal of this glossary is to aid in discovery of
> term meanings, so knowing that two terms are interchangable is
> itself helpful
> It is my hope that this revision represents the final _structural_
> change to the glossary. New definitions and edits to existing
> definitions will, of course, go on forever.
Please find some minor suggestions in the attachment. They are based on
Corey's last patch 0001-glossary-v4.patch.
Kind regards, Jürgen
|Next Message||Justin Pryzby||2020-03-31 17:58:45||Re: Add A Glossary|
|Previous Message||Corey Huinker||2020-03-30 17:10:19||Re: Add A Glossary|
|Next Message||Masahiko Sawada||2020-03-31 14:16:20||Re: Race condition in SyncRepGetSyncStandbysPriority|
|Previous Message||Julien Rouhaud||2020-03-31 14:08:55||Re: WAL usage calculation patch|