|From:||Michael Paquier <michael(at)paquier(dot)xyz>|
|To:||Peter Eisentraut <peter(dot)eisentraut(at)2ndquadrant(dot)com>|
|Cc:||Michael Paquier <michael(dot)paquier(at)gmail(dot)com>, Thomas Munro <thomas(dot)munro(at)enterprisedb(dot)com>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Postgres hackers <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: Disabling src/test/[ssl|ldap] when not building with SSL/LDAP support|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
On Wed, Feb 28, 2018 at 10:02:37AM -0500, Peter Eisentraut wrote:
> On 2/24/18 18:29, Michael Paquier wrote:
>> Sure. But then I think that it would be nice to show up on screen the
>> reason why the test failed if possible. As of now if SSL is missing the
>> whole run shows in red without providing much useful information.
>> Instead of 0001 as shaped previously, why not using as well diag to show
>> the failure on the screen?
>> For example the following block at the top of each test:
>> if (!check_pg_config("#define USE_OPENSSL 1"))
>> diag "SSL tests not supported without support in build";
> I think BAIL_OUT() is intended for this.
That's a better idea. I have reworked that in 0001. What do you think?
This has the same effect as diag(), which shows information directly to
the screen, and that's the behavior I was looking for.
>>> What I had in mind would consist of something like this in
>>> ifeq ($(with_ldap),yes)
>>> ifneq (,$(filter ldap,$(YOUR_VARIABLE_HERE)))
>>> SUBDIRS += ldap
>> OK. So let's call it PG_TEST_EXTRA_INSECURE or PG_TEST_EXTRA, which can
>> take 'ldap', 'ssl' or 'ldap,ssl' as valid values. Seeing that
>> documented is really necessary in my opinion. Any idea for a better
> I don't have a great idea about the name. The value should be
> space-separated to work better with make functions.
I have concluded about using the most simple name: PG_TEST_EXTRA. A
documentation attempt is added as well. This is unfortunately close to
EXTRA_TESTS. It would be tempting to directly reuse EXTRA_TESTS as
well, however this is used only for the core regression tests now, so a
separated variable seems adapted to me.
Thoughts and reviews are welcome.
|Next Message||Magnus Hagander||2018-03-02 08:42:41||Re: [HACKERS] log_destination=file|
|Previous Message||Marina Polyakova||2018-03-02 08:22:01||Re: WIP Patch: Precalculate stable functions, infrastructure v1|