|From:||Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>|
|To:||Pavel Borisov <pashkin(dot)elfe(at)gmail(dot)com>|
|Cc:||Emre Hasegeli <emre(at)hasegeli(dot)com>, Michael Paquier <michael(at)paquier(dot)xyz>, PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>|
|Subject:||Re: Bogus documentation for bogus geometric operators|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
Pavel Borisov <pashkin(dot)elfe(at)gmail(dot)com> writes:
>> undocumented. Maybe instead of removing, change the text to be
>> "Deprecated, use the equivalent XXX operator instead." Or we could
>> add a footnote similar to what was there for a previous renaming:
> The problem that this new <<| is equivalent to <^ only for points (To
> recap: the source of a problem is the same name of <^ operator for points
> and boxes with different meaning for these types).
I don't think it's that hard to be clear; see proposed wording below.
The other loose end is that I don't think we can take away the opclass
entries for the old spellings, unless we're willing to visibly break
people's queries by removing those operator names altogether. That
doesn't seem like it'll fly when we haven't even deprecated the old
names yet. So for now, we have to support both names in the opclasses.
I extended the patch to do that.
This version seems committable to me --- any thoughts?
regards, tom lane
|Next Message||Ian Lawrence Barwick||2020-11-23 00:35:10||Re: [doc] improve tableoid description|
|Previous Message||Tomas Vondra||2020-11-22 22:07:09||Re: Why does create_gather_merge_plan need make_sort?|