Skip site navigation (1) Skip section navigation (2)

Request for help (desperate attempt III)... Can't compile DBD::Pg (under IRIX 5.3)

From: Stuart Rison <stuart(at)ludwig(dot)ucl(dot)ac(dot)uk>
To: Dana Hudes <dhudes(at)hudes(dot)org>
Cc: dbi-users(at)isc(dot)org, pgsql-interfaces(at)hub(dot)org, E(dot)Mergl(at)bawue(dot)de
Subject: Request for help (desperate attempt III)... Can't compile DBD::Pg (under IRIX 5.3)
Date: 1999-07-19 18:37:03
Message-ID: v04020a03b3b91ce6d70f@[128.40.242.190] (view raw or whole thread)
Thread:
Lists: pgsql-interfaces
Dear all,

I rebouncing this to the community!

I still have not been able to compile DBD::Pg under IRIX 5.3 for a system
running postgreSQL 6.4.0.

I used to have a system running DBI 1.02 and DBD::Pg 0.79 but I wanted to
upgrade to get better support for NULLs.

I tried the following:

1) Updated to DBI 1.19 with no problems
2) Tried -unsuccessfully- to update to DBD::Pg 0.92
3) Read the README and found out the DBD::Pg 0.92 is only compatible with
postgreSQL 6.4.2 onwards
4) Uninstalled DBD::Pg 0.92 and tried -unsuccessfully- to install DBD::Pg
0.89 (the latest version compatible with postgreSQL 6.4.0)
5) Posted post I to dbi-users and pgsql-interfaces
6) Got an answer from Dana suggesting there may be an incompatibility issue
between newer/current versions of DBI and older versions of DBD::Pg
7) Uninstalled DBI 1.13 and successfully reinstalled DBI 1.02 (dates seem
to suggest that that is the most recent DBI compatible with DBD::Pg 0.89)
8) Tried -unsuccessfully- to install DBD::Pg 0.89

in all cases where the DBD::Pg (0.89 and 0.92) install failed (2,4 and 8),
I get the same error message:

cfe: Warning 608: ./Pg.h: 24: Undefined the ANSI standard library defined
macro BUFSIZ (4.1.2.1(9))
        cc -c -I/usr/local/pgsql/include -I/usr/local/include/pgsql
-I/usr/include/pgsql -I/usr/local/lib/perl5/site_perl/IP22-irix/auto/DBI
-I/usr/local/lib/perl5/IP22-irix/5.00404/DBI -I/auto/DBI -I/DBI
-D_POSIX_SOURCE -ansiposix -D_BSD_TYPES -Olimit 30
cfe: Warning 608: ./Pg.h: 24: Undefined the ANSI standard library defined
macro BUFSIZ (4.1.2.1(9))
cfe: Error: dbdimp.c, line 831: Incompatible pointer type assignment
(3.3.16.1, 3.5.4.1(21))
                 val = (((phs->sv)->sv_flags  & 0x00040000 )  ? (( len =
((XPV*)  (phs->sv)->sv_any )->xpv_cur ), ((XPV*)  (phs->sv)->sv_any
)->xpv_pv ) : Perl_sv_2pv (phs->sv, & len)) ;
 -------------------------------------------------------------------------------
--------------------------------------------------------------------------------
-----------------^
cfe: Error: dbdimp.c, line 831: Type int *  of this argument  is
incompatible with type STRLEN *  of function prototype description
(3.3.16.1)
                 val = (((phs->sv)->sv_flags  & 0x00040000 )  ? (( len =
((XPV*)  (phs->sv)->sv_any )->xpv_cur ), ((XPV*)  (phs->sv)->sv_any
)->xpv_pv ) : Perl_sv_2pv (phs->sv, & len)) ;
 -------------------------------------------------------------------------------
--------------------------------------------------------------------------------
-----------------^
*** Error code 1 (bu21)

I can e-mail full details (e.g. full make output, perl -V and perl -v
outputs etc) to you or you can find them in a previous posting entitled:
"Problems compiling DBD::Pg under IRIX 5.3".

Please, please help if you can as I'm beginign to hear voices in my head
telling me to chuck my trusty Indigo2 out of the window!

Cheers,

Stuart

At 4:56 pm +0100 19/7/99, Stuart Rison wrote:
>    *** From dbi-users -- To unsubscribe, see the end of this message. ***
>
>Dear Dana,
>
>Thanks for your posting, unfortunately upgrading to PG 6.5.x is currently
>not an option for me although it may be in the future.  I'm glad to hear
>that installation should be trouble free if I choose that route.
>
>I must say I think something more 'obscure' is going on as the error
>message seems to indicate a problem with the source code rather that the
>versions of DBI and DBD.
>
>With best regards,
>
>Stuart
>
>>Stuart, Postgres is up to 6.5, with 6.5.1 coming shortly. The latest perl
>>(and tcl) interfaces are built when you build Postgres.
>>Worked for me.
>>
>>> <snip - the error message I get when I try to compile DBD::Pg 0.89 under
>>>IRIX 5.3>
+--------------------------+--------------------------------------+
| Stuart C. G. Rison       | Ludwig Institute for Cancer Research |
+--------------------------+ 91 Riding House Street               |
| N.B. new phone code!!    | London, W1P 8BT                      |
| Tel. +44 (0)207 878 4041 | UNITED KINGDOM                       |
| Fax. +44 (0)207 878 4040 | stuart(at)ludwig(dot)ucl(dot)ac(dot)uk              |
+--------------------------+--------------------------------------+

In response to

pgsql-interfaces by date

Next:From: Doug ThistlethwaiteDate: 1999-07-20 06:18:26
Subject: jdbc interface problems with jdk1.2
Previous:From: Neil DarlowDate: 1999-07-19 15:16:09
Subject: Qualified Table Name and PsqlODBC.

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group