Re: GnuTLS support

From: Andreas Karlsson <andreas(at)proxel(dot)se>
To: Jeff Janes <jeff(dot)janes(at)gmail(dot)com>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: GnuTLS support
Date: 2017-09-17 21:17:37
Message-ID: e3435ba5-95fd-77f8-de2f-c1117b143d62@proxel.se
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

On 09/15/2017 06:55 PM, Jeff Janes wrote:
> I can't build against gnutls-2.12.23-21.el6.x86_64 from CentOS 6.9

Thanks for testing my patch. I have fixed both these issues plus some of
the other feedback. A new version of my patch is attached which should,
at least on theory, support all GnuTLS versions >= 2.11.

I just very quickly fixed the broken SSL tests, as I am no fan of how
the SSL tests currently are written and think they should be cleaned up.

Andreas

Attachment Content-Type Size
gnutls-v2.patch text/x-patch 75.8 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Thomas Munro 2017-09-17 21:31:33 Re: Improving DISTINCT with LooseScan node
Previous Message Alvaro Herrera 2017-09-17 20:45:06 Re: Log LDAP "diagnostic messages"?