From: Vik Fearing <vik(at)postgresfriends(dot)org>
To: Dean Rasheed <dean(dot)a(dot)rasheed(at)gmail(dot)com>, Isaac Morland <isaac(dot)morland(at)gmail(dot)com>
Cc: PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>
Subject: Re: MERGE ... RETURNING
Date: 2023-01-09 16:23:04
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

On 1/9/23 13:29, Dean Rasheed wrote:
> On Sun, 8 Jan 2023 at 20:09, Isaac Morland <isaac(dot)morland(at)gmail(dot)com> wrote:
>> Would it be useful to have just the action? Perhaps "WITH ACTION"? My idea is that this would return an enum of INSERT, UPDATE, DELETE (so is "action" the right word?). It seems to me in many situations I would be more likely to care about which of these 3 happened rather than the exact clause that applied. This isn't necessarily meant to be instead of your suggestion because I can imagine wanting to know the exact clause, just an alternative that might suffice in many situations. Using it would also avoid problems arising from editing the query in a way which changes the numbers of the clauses.
> Hmm, perhaps that's something that can be added as well. Both use
> cases seem useful.

Bikeshedding here. Instead of Yet Another WITH Clause, could we perhaps
make a MERGING() function analogous to the GROUPING() function that goes
with grouping sets?

RETURNING *, MERGING('clause'), MERGING('action');

Or something.
Vik Fearing

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Laurenz Albe 2023-01-09 16:40:01 Re: Make EXPLAIN generate a generic plan for a parameterized query
Previous Message Dean Rasheed 2023-01-09 16:12:37 Re: [PATCH] random_normal function