Skip site navigation (1) Skip section navigation (2)

Re: initdb failure with PostgreSQL 7.3.2 / Cygwin 1.3.22-1 /

From: Frank Seesink <frank(at)mail(dot)wvnet(dot)edu>
To: pgsql-cygwin(at)postgresql(dot)org
Subject: Re: initdb failure with PostgreSQL 7.3.2 / Cygwin 1.3.22-1 /
Date: 2003-05-05 19:36:56
Message-ID: b96eei$s00$ (view raw, whole thread or download thread mbox)
Lists: pgsql-cygwin
Jason Tishler wrote:
> Frank,
> On Mon, May 05, 2003 at 08:13:01AM -0400, Jason Tishler wrote:
>>On Fri, May 02, 2003 at 06:11:06PM -0400, Frank Seesink wrote:
>>>It's as if the copy of ipc-daemon running in the 'postgres' context
>>>is oblivious to the copy running as Local System account.
>>Yes.  I believe understanding the above will lead to the root cause of
>>this problem.
> I did some more Googling.  Does the following apply to your setup?


	After my last post regarding the above link, I switched over to the 
'postgres' account and tried 'ipctest s' and it worked!!!  GAAH!  I 
started feeling like Markko Paas (the thread that started on 16 Jan 
2003) which culminated with him posting on 22 Jan 2003 that

	..."ipctest s" started working "out of blue"

but I wanted to get to the bottom of this, once and for all.  Then this 
post of yours tickled my brain.

	Turns out you da man!  I think you may have found the culprit!  You 
see, I had LOGGED OUT as 'Frank', then logged in as 'postgres'.  To test 
my theory, I logged out of 'postgres', logged back in as 'Frank', then 
switched ([WindowKey]-L) out and logged in as 'postgres'.  Sure enough, 
'ipctest s' failed!

	I have now tested further by logging back in as 'Frank' (needed admin 
rights) and doing

	$ net stop ipc-daemon
	$ rm /tmp/MultiFile*

then rebooting (ipc-daemon is set as a service to start 
'Automatically'), logged in as 'postgres', and ran 'ipctest s'.  It worked!

	Darn it all to heck, that stupid Windows Terminal Services issue is 
STILL there!!!  Now, I have no clue how you switch it from 'Remote 
Administration' mode to 'Application Server' mode.  But I believe the 
very act of using the Fast User Switching (where you 'Switch Users' 
without logging out) is what is causing this.

	I have tried this several times now, and it consistently points to the 
fact that if you run ipctest when you have another account logged in 
(and that's IT no need to be running any Cywgin apps, the BASH 
shell, whatnot), ipctest fails.  I have no clue whether this would also 
apply if someone used the VPN server feature in XP Pro and up, but note 
that the 'Fast User Switch Compatibility' NT service (as well as others) 
all rely on the 'Terminal Services' NT service, so what you may be 
looking at here is a cascading effect:  any action/service that relies 
on 'Terminal Services' may trigger this gotcha.

	For a final test, I am going to blow away the entire Cygwin 
distribution install, clean house on the Registry, etc., and start anew. 
  I will then install Cygwin as I always have done, and simply avoid 
doing any user context switching.  If I have any difficulties, I suspect 
they may be with the default file permissions of the /tmp and /usr/bin 
directories.  I will simply do the steps as outlined in the PostgreSQL 
README for starters, however, and once done, I'll let you know what 
steps are required beyond the basic install (like possibly 'chmod 777 
/tmp' and 'chmod 755 /usr/bin /usr/bin/*').

	This information may come in handy for others trying to install/run 
PostgreSQL on Cywgin under Windows XP.

	Again, thanks for the diligence in this, Jason.  I'll try to 
reciprocate the favor now in what little way I can (though may not post 
'til morning depending how long it takes me).  I want to know this for 
my own sake as much as for helping others.  I don't want to see 
PostgreSQL stop 'out of the blue' any more than the next guy. :-)

In response to


pgsql-cygwin by date

Next:From: Andrew BaileyDate: 2003-05-05 21:15:59
Subject: Re: initdb failure with PostgreSQL 7.3.2 / Cygwin 1.3.22-1 /
Previous:From: Frank SeesinkDate: 2003-05-05 18:47:40
Subject: Re: initdb failure with PostgreSQL 7.3.2 / Cygwin 1.3.22-1 /

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group