| From: | Michael Paquier <michael(at)paquier(dot)xyz> |
|---|---|
| To: | Zsolt Parragi <zsolt(dot)parragi(at)percona(dot)com> |
| Cc: | Andrey Borodin <x4mmm(at)yandex-team(dot)ru>, Nikolay Samokhvalov <nik(at)postgres(dot)ai>, pgsql-hackers(at)lists(dot)postgresql(dot)org |
| Subject: | Re: injection_points: canceled or terminated waiters leak their wait slots |
| Date: | 2026-10-02 23:48:00 |
| Message-ID: | asBCsCfFefC4lMQE@paquier.xyz |
| Views: | Whole Thread | Raw Message | Download mbox | Resend email |
| Thread: | |
| Lists: | pgsql-hackers |
On Fri, Oct 02, 2026 at 10:44:20PM +0100, Zsolt Parragi wrote:
> I only disabled the two tests that already had failures on CI. After
> looking into it again I realized that temp-schema-cleanup could only
> fail with my hacked together linux repro, I can't reproduce it on
> windows. In wait_cleanup and slot_creation_error one session kills
> another session.
Thanks for the patch. That should be able to do the job. Good idea
to mention the thread, for future references.
> In temp-schema-cleanup s1 kills itself. When the
> fatal happens the isolation tester is reading s1's socket, and
> receives the message properly, I can't make that fail without
> modifying the testcase.
Okay, that's good to know. That leads to an even simpler patch.
--
Michael
| From | Date | Subject | |
|---|---|---|---|
| Next Message | Laurenz Albe | 2026-10-03 01:25:49 | Re: Adding a stored generated column without long-lived locks |
| Previous Message | Andrew Dunstan | 2026-10-02 21:48:55 | Re: Allow table AMs to define their own reloptions |