> You may want to name your patches with .patch or .diff. Using .sql is > disturbing style :)
> Indeed, not reporting the progress back to the client in the case of a > script with only meta commands is non-intuitive. > > This looks good to me. I'd just rewrite the comment block with > something like that, more simplified:
Ok. Here is an updated version, with a better suffix and a simplified comment.