Skip site navigation (1) Skip section navigation (2)

Re: Unable to install DBD module

From: ghaverla(at)freenet(dot)edmonton(dot)ab(dot)ca
To: James Hall <James(dot)Hall(at)RadioShack(dot)com>
Cc: pgsql-novice(at)hub(dot)org
Subject: Re: Unable to install DBD module
Date: 2000-09-15 14:05:28
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-novice
On Fri, 15 Sep 2000, James Hall wrote:

> I am trying to install the DBD module and having some problems...
> -When trying to install 'DBD-Pg-0.95.tar.gz' I receive the following error
> after running 'perl Makefile.PL':
> "... Please set environment variables POSTGRES_INCLUDE and POSTGRES_LIB !"

Okay, it sounds like you don't understand the error message.
Do you know what it means to set an environment variable?
PATH is one environment variable which most people know of.
If you 'echo $PATH' on a command line, it will tell you the
contents of the PATH variable.  The perl install program needs
to use the contents of the POSTGRES_INCLUDE and POSTGRES_LIB
variables in order to properly install itself.  When the install
program ran, it found those variables either not defined, or if
defined their contents were empty.  The INLCUDE variable needs
to contain the path to some header file (Pg.h ?), and the LIB
variable needs to include the path to some library file ( ?).
If you were running bash as a shell, and the header file was in the
directory /tmp, you could set the variable as:
(Note, this will not be the path for your, or any other system.)

> -When trying to install 'DBD-Pg-0.73-1.i386.rpm' I receive the following
> error:

So, when a source code install of the 0.95 version of DBD failed,
you tried a binary install of 0.73.  There is nothing particularly
wrong with trying to install a binary version of an older package,
I hope you at least tried to uninstall the source version of the
newer package.  No sense cluttering things up too much.

> "DBI is needed by DBD-Pg-0.73-1" [which is installed...] and " is
> needed by DBD-Pg-0.73-1"

And the 0.73 version still needs POSTGRES_LIB to point at the library file (or you don't have the library installed).

> -When trying to install 'perl-DBD-Pg-0.91-2.i386.rpm' I receive the
> following error:
> " is needed by perl-DBD-Pg-0.91-2"

And now we try yet another package, again binary.  It too needs
to find a version of the library, this time at revision

I run a system that uses DEBs, not RPMs, but I thought RPM
would handle the library location.  Usually, one doesn't need
to set environment variables when using these binary packages,
this is usually set somewhere inside the package if it needs to be.
However, their are quite a few flavours of RPM, and maybe you are
using the wrong flavour of RPM.  Did you get your RPM from
Or is it maybe that you got a SuSE or some other kind of RPM from
rpmfind?  It might be that the RPM you were trying to install is
looking someplace other than /usr/lib.

I don't really see anything wrong with how you tried to install
the RPMs, I suspect you just used the wrong kind of RPM (SuSE
or Mandrake or .... instead of RedHat).  This problem has more to
do with different distributions putting files in different places
than anything being incompatible.  You could set up symbollic links
(don't copy the files, that wastes space.  don't move the file,
you might break programs already installed and working) to enable
the installation to run to completion.


Matter Realisations
Gordon Haverland, B.Sc. M.Eng. President
101  9504 182 St. NW    Edmonton, AB, CA  T5T 3A7
780/481-8019            ghaverla @

In response to


pgsql-novice by date

Next:From: Tom LaneDate: 2000-09-15 14:18:45
Subject: Re: Trouble Compiling Postgres 7.0.2 under Windows
Previous:From: James HallDate: 2000-09-15 13:22:35
Subject: Unable to install DBD module

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group