BUG #8347: PANIC: heap_insert_redo: failed to add tuple when applying WAL

From: maciek(at)heroku(dot)com
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #8347: PANIC: heap_insert_redo: failed to add tuple when applying WAL
Date: 2013-07-31 01:27:39
Message-ID: E1V4LCV-0007AE-8p@wrigleys.postgresql.org
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-bugs

The following bug has been logged on the website:

Bug reference: 8347
Logged by: Maciek Sakrejda
Email address: maciek(at)heroku(dot)com
PostgreSQL version: 9.2.4
Operating system: Ubuntu 12.04.2 LTS 64-bit
Description:

Running into a recovery failure on a customer's replica:

Jul 31 00:11:55: LOG: restored log file "00000001000000E200000067" from
archive
Jul 31 00:11:55: WARNING: will not overwrite a used ItemId
Jul 31 00:11:55: CONTEXT: xlog redo insert: rel 1663/16385/16619; tid
25260/37
Jul 31 00:11:55: PANIC: heap_insert_redo: failed to add tuple
Jul 31 00:11:55: CONTEXT: xlog redo insert: rel 1663/16385/16619; tid
25260/37

I see a similar bug filed [1], but no replies. This happens repeatedly when
attempting to apply this segment.

[1]:
http://www.postgresql.org/message-id/CANbzriT3h1kf2EaKEBcDqwu4AYwUjCuKcrDkjdxJ0CTjNeGnFQ@mail.gmail.com

Responses

Browse pgsql-bugs by date

  From Date Subject
Next Message Andres Freund 2013-07-31 04:28:32 Re: BUG #8347: PANIC: heap_insert_redo: failed to add tuple when applying WAL
Previous Message devadas_mallya 2013-07-30 21:58:55 BUG #8346: Postgres BDR: Segmentation Fault observed during replication of binary object.