Re: PG18: use-after-free in exec partition pruning after an EPQ recheck in LockRows

From: Vladimir Savin <vladimir(at)encord(dot)com>
To: Andrey Rachitskiy <pl0h0yp1(at)gmail(dot)com>
Cc: pgsql-bugs(at)lists(dot)postgresql(dot)org
Subject: Re: PG18: use-after-free in exec partition pruning after an EPQ recheck in LockRows
Date: 2026-10-02 08:12:31
Message-ID: CAP2G_gEi_d5EuZKJEQCyxsAJ_tpT68kw9JpnfiMTfx2vH_evAw@mail.gmail.com
Views: Whole Thread | Raw Message | Download mbox | Resend email
Thread:
Lists: pgsql-bugs

On Fri, 2 Oct 2026 at 09:04, Andrey Rachitskiy <pl0h0yp1(at)gmail(dot)com> wrote:
> Also, a small request for future threads: please reply inline
> (bottom-posting) — trim quotes and answer below the relevant part.

Got it, thank you Andrey!

--
*This email and any files transmitted with it are confidential and intended
solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error, please notify the sender
immediately by replying to this email and delete it from your system.
Please do not copy, distribute, or take action based on the contents of
this email if you are not the intended recipient. Any unauthorized use or
disclosure of this email's contents is strictly prohibited.*

In response to

Browse pgsql-bugs by date

  From Date Subject
Next Message Jiří Kavalík 2026-10-02 08:29:03 Re: Streaming decoding fails with "unexpected table_index_fetch_tuple call during logical decoding" when a relation has a TOASTed conbin (follow-up to BUG #18641)
Previous Message Andrey Rachitskiy 2026-10-02 08:04:03 Re: PG18: use-after-free in exec partition pruning after an EPQ recheck in LockRows