2016-12-05 0:45 GMT+01:00 Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>:
> Pavel Stehule wrote:
> > 2016-12-04 23:00 GMT+01:00 Pavel Stehule <pavel(dot)stehule(at)gmail(dot)com>:
> > > I am not sure if I understand well to your ideas - please, check
> > > patch.
> Thanks, that's what I meant, but I think you went a bit overboard
> creating new functions in execQual -- seems to me it would work just
> fine to have the memory switches in the same function, rather than
> having a number of separate functions just to change the context then
> call the method. Please remove these shim functions.
> Also, you forgot to remove the now-unused per_rowset_memcxt struct member.
> Also, please rename "rc" to something more meaningful -- maybe
> "rowcount" is good enough. And "doc" would perhaps be better as
> I'm not completely sure the structs are really sensible yet. I may do
> some more changes tomorrow.
> Álvaro Herrera https://www.2ndQuadrant.com/
> PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
In response to
pgsql-hackers by date
|Next:||From: Michael Paquier||Date: 2016-12-05 06:26:09|
|Subject: Re: commitfest 2016-11 status summary|
|Previous:||From: Haribabu Kommi||Date: 2016-12-05 05:55:11|
|Subject: Re: Transactions involving multiple postgres foreign servers|