|From:||Daniel Gustafsson <daniel(at)yesql(dot)se>|
|To:||Stephen Frost <sfrost(at)snowman(dot)net>|
|Cc:||pgsql-hackers(at)lists(dot)postgresql(dot)org, Bruce Momjian <bruce(at)momjian(dot)us>|
|Subject:||Re: Default role -> Predefined role|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
> On 20 Nov 2020, at 22:13, Stephen Frost <sfrost(at)snowman(dot)net> wrote:
> Attached is a patch to move from 'default role' terminology to
> 'predefined role' in the documentation. In the code, I figured it made
> more sense to avoid saying either one and instead opted for just
> 'ROLE_NAME_OF_ROLE' as the #define, which we were very close to (one
> removing the 'DEFAULT' prefix) but didn't actually entirely follow.
Predefined is a much better terminology than default for these roles, makes the
concept a lot clearer. +1 on this patch.
> I had contemplated calling these 'capabilities' or similar but ended up
> deciding not to- they really are roles, after all.
Agreed, roles is better here.
|Next Message||David Rowley||2020-12-06 23:46:12||Re: Hybrid Hash/Nested Loop joins and caching results from subplans|
|Previous Message||Konstantin Knizhnik||2020-12-06 20:50:51||Wrong check in pg_visibility?|