Re: Types not exported/restored

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: BIBICO <bpvelonza(at)gmail(dot)com>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: Types not exported/restored
Date: 2008-07-11 07:26:46
Message-ID: 48770B36.8030209@lelarge.info
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgadmin-support

BIBICO a écrit :
> I am trying to do a backup/transfer of database, and possibly the whole
> server from one computer to another in a network using Pgadmin III included
> in PostgreSQL 8.2. Tables were exported but nothing was exported in types.
> Hence, some columns of the tables are missing, I've noticed that these are
> tables having dependents in Types(which is missing) . Added to that, only
> the public schema was exported and restored but not the other schemas. How
> could I totally backup the whole database from one computer to another
> completely?
>
> I am new to using PostgreSQL and database as a whole and just starting to
> learn.
> I am dying for almost a week looking for the answer
> Help please... Thanks :)
> -these are the screenshots to better explain a novice like me :)
> fist one is the screenshot of the db to backup, the 2nd one is incomplete
> the restored db
> http://www.nabble.com/file/p18395521/db_source.jpg
> http://www.nabble.com/file/p18395521/db_restored.jpg
>

I don't think you're using the same version of pgAdmin. The first
screenshot shows system schemas in the Schemas node, and in the second
screenshot, there are in the Catalogs node.

Anyways, the first screenshot shows only one schema (public). All others
are system ones. They won't be part of a dump.

So I don't see any issue here. If you had errors during restore, please
show them.

Regards.

--
Guillaume.
http://www.postgresqlfr.org
http://dalibo.com

In response to

Responses

Browse pgadmin-support by date

  From Date Subject
Next Message BIBICO 2008-07-11 09:48:27 Re: Types not exported/restored
Previous Message sfmei2003 2008-07-11 05:11:58 Couldn't connect to database under Vista