|From:||Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>|
|To:||Haribabu Kommi <kommi(dot)haribabu(at)gmail(dot)com>|
|Cc:||Ashutosh Bapat <ashutosh(dot)bapat(at)enterprisedb(dot)com>, Michael Paquier <michael(dot)paquier(at)gmail(dot)com>, Simon Riggs <simon(at)2ndquadrant(dot)com>, "pgsql-hackers(at)postgresql(dot)org" <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: pg_hba_file_settings view patch|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
Haribabu Kommi <kommi(dot)haribabu(at)gmail(dot)com> writes:
> [ pg_hba_rules_13.patch ]
I spent awhile hacking on this, and made a lot of things better, but
I'm still very unhappy about the state of the comments. You changed
the APIs of a bunch of functions, often into fairly subtle things,
and you did not touch even one of their API-specification comments.
As an example, next_token() now needs something like
"On error, log a message at ereport level elevel and set *err_msg to
an error string. Note that the return value might be either true or
false after an error; *err_msg must be checked to determine that.
Hence, *err_msg had better be NULL on entry, or you won't be able
Having to write such a thing might even convince you that you should
try a little harder to make the behavior less confusing. Just adding
arguments, and not changing the result-value specification, is not
necessarily the best way to do this.
I haven't looked at the docs yet.
I'm still not very happy about the choice of view name ...
regards, tom lane
|Next Message||Michael Paquier||2017-01-27 23:47:03||Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal|
|Previous Message||Andres Freund||2017-01-27 23:13:38||Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal|