Re: renaming ExecStoreWhateverTuple

From: Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>
To: Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>
Subject: Re: renaming ExecStoreWhateverTuple
Date: 2019-03-25 15:27:52
Message-ID: 20190325152751.GA15490@alvherre.pgsql
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

I agree about taking out the "Exec" part of the name.

On 2019-Mar-25, Robert Haas wrote:

> I'm not sure exactly what names would be better. Perhaps just change
> the "Exec" prefix to "Slot", e.g. SlotStoreHeapTuple(). Or maybe put
> InSlot at the end, like StoreHeapTupleInSlot(). Or just take those
> four words - slot, heap, tuple, and store - and put them in any order
> you like. TupleSlotStoreHeap?


(I wonder why not "Put" instead of "Store".)

Should we keep ExecStoreTuple as a compatibility macro for third party

Álvaro Herrera
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Nikita Glukhov 2019-03-25 15:29:58 Re: [PATCH] kNN for btree
Previous Message Peter Eisentraut 2019-03-25 15:23:34 Re: REINDEX CONCURRENTLY 2.0