|From:||Michael Paquier <michael(at)paquier(dot)xyz>|
|To:||Michael Banck <michael(dot)banck(at)credativ(dot)de>|
|Cc:||Postgres hackers <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: Offline enabling/disabling of data checksums|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
On Sat, Dec 22, 2018 at 02:42:55PM +0100, Michael Banck wrote:
> On Sat, Dec 22, 2018 at 08:28:34AM +0900, Michael Paquier wrote:
>> There are two discussion points which deserve attention here:
>> 1) Do we want to rename pg_verify_checksums to something else, like
>> pg_checksums. I like a lot if we would do a simple renaming of the
>> tool, which should be the first step taken.
> I am for it, but don't mind whether it's before or afterwards, your
Doing the renaming after would be a bit weird logically, as we would
finish with a point in time in the tree where pg_verify_checksums is
able to do something else than just verifying checksums.
> Even though my fork has the separate switches, I like the --action one.
> On the other hand, it is a bit more typing as you always have to spell
> out the action (is there precendent of accepting also incomplete option
> arguments like 'v', 'e', 'd'?).
Yes, there is a bit of that in psql for example for formats. Not sure
that we should take this road for a checksumming tool though. If a
new option is added which takes the first letter then we would have
incompatibility issues. That's unlikely to happen, still that feels
|Next Message||Heikki Linnakangas||2018-12-23 00:45:05||Re: Speeding up text_position_next with multibyte encodings|
|Previous Message||Michael Paquier||2018-12-23 00:35:29||Re: [PATCH] Improve tab completion for CREATE TABLE|