|From:||Michael Paquier <michael(at)paquier(dot)xyz>|
|To:||Etsuro Fujita <fujita(dot)etsuro(at)lab(dot)ntt(dot)co(dot)jp>|
|Cc:||Ashutosh Bapat <ashutosh(dot)bapat(at)enterprisedb(dot)com>, pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: de-deduplicate code in DML execution hooks in postgres_fdw|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
On Thu, Jul 19, 2018 at 05:35:11PM +0900, Etsuro Fujita wrote:
> +1 for the general idea. (Actually, I also thought the same thing before.)
> But since this is definitely a matter of PG12, ISTM that it's wise to work
> on this after addressing the issue in . My concern is: if we do this
> refactoring now, we might need two patches for fixing the issue in case of
> backpatching as the fix might need to change those executor functions.
FWIW, I would think that if some cleanup of the code is obvious, we
should make it without waiting for the other issues to settle down
because there is no way to know when those are done, and this patch
could be forgotten. This indeed makes back-patching a bit harder but it
also reduces the code chunk for HEAD with the extra fixes.
Looking at the proposed patch, moving the new routine closer to
execute_dml_stmt and renaming it execute_dml_single_row would be nicer.
|Next Message||David Fetter||2018-07-20 05:06:37||Re: Make foo=null a warning by default.|
|Previous Message||Michael Paquier||2018-07-20 04:25:20||Re: [HACKERS] Restricting maximum keep segments by repslots|