Re: Review: DTrace probes (merged version)

From: Alvaro Herrera <alvherre(at)commandprompt(dot)com>
To: Zdenek Kotala <Zdenek(dot)Kotala(at)Sun(dot)COM>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>, Robert Lor <Robert(dot)Lor(at)Sun(dot)COM>, Robert Treat <xzilla(at)users(dot)sourceforge(dot)net>, jesus(at)omniti(dot)com
Subject: Re: Review: DTrace probes (merged version)
Date: 2008-07-04 15:05:40
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

Zdenek Kotala wrote:

> 1) Naming convention:
> - Some probes uses "*end", some "*done". It would be good to select one name.
> - I prefer to use clog instead of slru in probes name. clog is widely known.

But slru is also used in pg_subtrans and pg_multixact. Which maybe
says that we oughta have separate probes for these rather than a single
one in slru. Otherwise it's going to be difficult telling one from the
other, yes?

> Autovacuum_start probe is alone. I propose following probes for completeness:
> proc-autovacuum-start
> proc-autovacuum-stop
> proc-bgwriter-start
> proc-bgwriter-stop

Separate proc-autovacuum-worker-start and proc-autovacuum-launcher-start,
perhaps. Not that I see any usefulness in tracking autovacuum launcher
start and stop, but then if we're tracking bgwriter start and stop then
it makes the same sense.

> proc-master-start
> proc-master-stop

What's "master" here?

Alvaro Herrera
PostgreSQL Replication, Consulting, Custom Development, 24x7 support

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Tom Lane 2008-07-04 15:53:56 Re: gsoc, text search selectivity and dllist enhancments
Previous Message Zdenek Kotala 2008-07-04 14:38:06 Review: DTrace probes (merged version)