Re: Cygwin on Win98: initdb failed

From: "Mike G(dot)" <mike(at)thegodshalls(dot)com>
To: Christian Rank <christian(dot)rank(at)rz(dot)uni-passau(dot)de>
Cc: pgsql-cygwin(at)postgresql(dot)org
Subject: Re: Cygwin on Win98: initdb failed
Date: 2004-09-21 04:39:59
Message-ID: 20040921043959.GA22835@localhost.localdomain
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-cygwin

Hi,

Postgres hasn't worked on Win98 since Cygwin switched to cygserver for memory management instead of ipc_daemon. I believe 7.4.3 was the version to require cygserver to run.

Mike
>
> On Mon, Sep 20, 2004 at 08:42:50AM +0200, Christian Rank wrote:
> > Hello,
> >
> > I'm trying to run the Cygwin version of PostgreSQL on Windows 98 SE.
> > During initdb, creation of the initial database cluster is aborted with
> > the message
> > creating template1 database in /var/pgsql/data/base/1...
> > shmat(id=1179648) failed: invalid argument
> >
> > The sequence of commands leading to this is as follows:
> >
> > mkdir /var/pgsql
> > export CYGWIN=server
> > /usr/bin/cygserver-config -n
> > /usr/sbin/cygserver -E &
> > mkdir /var/pgsql/data
> > initdb -D /var/pgsql/data -E LATIN1
> >
> > Software versions used:
> > cygwin 1.5.11-1
> > PostgreSQL 7.4.5-1
> > Windows 98 Second Edition 4.10.2222 A
> >
> > The same setup runs on Windows 2000 without problems. According to the
> > cygserver docs, it should run on Win98, too.
> >
> > Does anybody know what's going wrong here?
> >
> > Thanks in advance,
> > Christian
> >
> > --
> > Dr. Christian Rank
> > Rechenzentrum Universit├Ąt Passau
> > Innstr. 33
> > D-94032 Passau
> > GERMANY
> > Tel.: 0851/509-1838
> > Fax: 0851/509-1802
> > PGP public key see http://www.rz.uni-passau.de/mitarbeiter/rank
> >
> >
> > ---------------------------(end of broadcast)---------------------------
> > TIP 1: subscribe and unsubscribe commands go to majordomo(at)postgresql(dot)org

In response to

Responses

Browse pgsql-cygwin by date

  From Date Subject
Next Message Mike G. 2004-09-21 04:40:54 Re: 7.4.5 stopped working?
Previous Message Klint Gore 2004-09-21 00:38:43 7.4.5 stopped working?