RE: Timeout parameters

From: "Tsunakawa, Takayuki" <tsunakawa(dot)takay(at)jp(dot)fujitsu(dot)com>
To: "Nagaura, Ryohei" <nagaura(dot)ryohei(at)jp(dot)fujitsu(dot)com>, "Jamison, Kirk" <k(dot)jamison(at)jp(dot)fujitsu(dot)com>
Cc: 'Michael Paquier' <michael(at)paquier(dot)xyz>, "AYahorau(at)ibagroup(dot)eu" <AYahorau(at)ibagroup(dot)eu>, 'Fabien COELHO' <coelho(at)cri(dot)ensmp(dot)fr>, "'pgsql-hackers(at)postgresql(dot)org'" <pgsql-hackers(at)postgresql(dot)org>, "MikalaiKeida(at)ibagroup(dot)eu" <MikalaiKeida(at)ibagroup(dot)eu>
Subject: RE: Timeout parameters
Date: 2019-02-21 07:09:33
Message-ID: 0A3221C70F24FB45833433255569204D1FB9ED53@G01JPEXMBYT05
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

From: Nagaura, Ryohei [mailto:nagaura(dot)ryohei(at)jp(dot)fujitsu(dot)com]
> BTW, tcp_user_timeout parameter of servers and clients have same name in
> my current implementation.
> I think it would be better different name rather than same name.
> I'll name them as the following a) or b):
> a) server_tcp_user_timeout and client_tcp_user_timeout
> b) tcp_user_timeout and user_timeout
> b) is the same as the naming convention of keepalive, but it is not
> user-friendly.
> Do you come up with better name?
> Or opinion?

a) is not always accurate, because libpq is also used in the server. For example, postgres_fdw and WAL receiver in streaming replication.

I'm OK with either the current naming or b). Frankly, I felt a bit strange when I first saw the keepalive parameters, wondering why the same names were not chosen.

Takayuki Tsunakawa

In response to

Browse pgsql-hackers by date

  From Date Subject
Next Message John Naylor 2019-02-21 07:26:25 Re: WIP: Avoid creation of the free space map for small tables
Previous Message Kyotaro HORIGUCHI 2019-02-21 07:05:55 Re: shared-memory based stats collector