[PATCH v20] GSSAPI encryption support

From: Robbie Harwood <rharwood(at)redhat(dot)com>
To: pgsql-hackers(at)postgresql(dot)org
Cc: Stephen Frost <sfrost(at)snowman(dot)net>, Nico Williams <nico(at)cryptonector(dot)com>, Michael Paquier <michael(at)paquier(dot)xyz>, Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>, David Steele <david(at)pgmasters(dot)net>
Subject: [PATCH v20] GSSAPI encryption support
Date: 2018-12-18 19:12:46
Message-ID: jlgy38mir81.fsf@redhat.com
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

Hello friends,

Attached please find version 20 of the GSSAPI encryption support. This
has been rebased onto master (thanks Stephen for calling out ab69ea9).
Other changes since v19 from Stephen's review:

- About 100 lines of new comments

- pgindent run over code (only the stuff I'm changing; it reports other
problems on master, but if I understand correctly, that's not on me to
fix here)

Thanks for the feedback! And speaking of feedback, this patch is in the
"Needs Review" state so if people have additional feedback, that would
be appreciated. I've CC'd people who I can remember reviewing before;
they should of course feel no obligation to review again if time
commitments/interests do not allow.

Thanks,
--Robbie

Attachment Content-Type Size
v20-libpq-GSSAPI-encryption-support.patch text/x-diff 79.2 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Alvaro Herrera 2018-12-18 21:01:59 Re: [HACKERS] CLUSTER command progress monitor
Previous Message Robbie Harwood 2018-12-18 18:50:47 cfbot run pgindent?