AW: BUG #16004: New Version pgrouting_96-2.6.3-1 has dependency to postgis25_96 in postgresql.org-Channel

From: "Zollinger Beat (OIZ)" <Beat(dot)Zollinger(at)zuerich(dot)ch>
To: "Zollinger Beat (OIZ)" <Beat(dot)Zollinger(at)zuerich(dot)ch>, "pgsql-bugs(at)lists(dot)postgresql(dot)org" <pgsql-bugs(at)lists(dot)postgresql(dot)org>
Subject: AW: BUG #16004: New Version pgrouting_96-2.6.3-1 has dependency to postgis25_96 in postgresql.org-Channel
Date: 2019-09-13 04:20:06
Message-ID: dbf754948ecf4b9eaef0f8d932bf79a0@zuerich.ch
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-bugs

I checked with the pgRouting project and got follow answer:

'Well, the pgRouting project is testing on Travis CI with PostGIS 2.4 for different versions of PostgreSQL: https://travis-ci.org/pgRouting/pgrouting/builds/582871360/config
So this shouldn't be a requirement from pgRouting side.'

Can the dependency been removed?

-----Urspr√ľngliche Nachricht-----
Von: PG Bug reporting form <noreply(at)postgresql(dot)org>
Gesendet: Donnerstag, 12. September 2019 13:18
An: pgsql-bugs(at)lists(dot)postgresql(dot)org
Cc: Zollinger Beat (OIZ) <Beat(dot)Zollinger(at)zuerich(dot)ch>
Betreff: BUG #16004: New Version pgrouting_96-2.6.3-1 has dependency to postgis25_96 in postgresql.org-Channel

The following bug has been logged on the website:

Bug reference: 16004
Logged by: Beat Zollinger
Email address: beat(dot)zollinger(at)zuerich(dot)ch
PostgreSQL version: 9.6.14
Operating system: Red Hat Enterprise Linux Server release 7.6 (Maipo
Description:

Updating pgrouting_96 to newest version (2.6.3) is not possible as it depends on postgis25:

yum upgrade pgrouting_96
Loaded plugins: enabled_repos_upload, langpacks, package_upload, product-id, search-disabled-repos, subscription-manager, tracer_upload
imx_3rd_party_software_misc_repository_3rd_party_software_misc
| 2.1 kB
00:00:00
imx_epel_repository_epel7_x86_64
| 2.4 kB
00:00:00
imx_postgresql_repository_postgresql_9_6
| 2.1 kB
00:00:00
imx_puppet_satellite58_repository_puppet7_x86_64_satellite58
| 2.1 kB
00:00:00
rhel-7-server-extras-rpms
| 2.0 kB
00:00:00
rhel-7-server-optional-rpms
| 1.8 kB
00:00:00
rhel-7-server-rh-common-rpms
| 2.1 kB
00:00:00
rhel-7-server-rpms
| 2.0 kB
00:00:00
rhel-7-server-satellite-tools-6.5-rpms
| 2.1 kB
00:00:00
rhel-7-server-supplementary-rpms
| 2.0 kB
00:00:00
Resolving Dependencies
--> Running transaction check
---> Package pgrouting_96.x86_64 0:2.6.2-1.rhel7 will be updated Package
---> pgrouting_96.x86_64 0:2.6.3-1.rhel7 will be an update
--> Processing Dependency: postgis25_96 >= 2.5 for package:
pgrouting_96-2.6.3-1.rhel7.x86_64
--> Finished Dependency Resolution
Error: Package: pgrouting_96-2.6.3-1.rhel7.x86_64
(imx_postgresql_repository_postgresql_9_6)
Requires: postgis25_96 >= 2.5

our source:
https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-7Server-x86_64

Not sure if the dependency is correct

In response to

Browse pgsql-bugs by date

  From Date Subject
Next Message Tom Lane 2019-09-13 04:29:17 Re: BUG #16006: Update queries fail on a table having any policy with a function that takes a whole-row var as arg
Previous Message Vinay Banakar 2019-09-13 04:13:21 Re: BUG #16006: Update queries fail on a table having any policy with a function that takes a whole-row var as arg