Skip site navigation (1) Skip section navigation (2)

Re: "/usr/bin" supposed to exist?

From: Frank Seesink <frank(at)mail(dot)wvnet(dot)edu>
To: pgsql-cygwin(at)postgresql(dot)org
Subject: Re: "/usr/bin" supposed to exist?
Date: 2003-10-07 02:50:17
Message-ID: blt9lg$ql6$ (view raw, whole thread or download thread mbox)
Lists: pgsql-cygwin
Jason Tishler wrote:
> Frank,
> On Sat, Oct 04, 2003 at 06:14:31PM -0400, Frank Seesink wrote:
>>Note I have not had an issue with apps not working when this occurs.  It 
>>is just that there does not "appear" to be a ./bin directory in /usr. 
>>All the usual commands, though, work to access the files at this mount 
>>point.  Very weird.
> Do you have /bin in your PATH?  If so, then this would explain the
> above.

Actually, I do have /bin in my PATH.  I do a very simple Cygwin install, 
and it appears to be there by default.  So yeah, that is likely why 
commands, etc., continue to work.  Though the strange thing is that when 
you do the umount command I mention, it sometimes happens that you can't 
just type 'mount''s as if /bin ISN'T in the PATH even though it is. 
  Very odd.

My comments regarding having to use the full path in rebuilding /usr/bin 
so you can see it via 'ls' were more in case Stephan did not have /bin 
in his PATH or found himself getting these kinds of error messages. 
When in doubt, absolute paths beat relative ones. ;-)

The issue of /usr/bin disappearing from listings, however, is an odd 
one.  Still not sure what causes it.  I remember the first time I 
noticed this and fixed it.  A few months later, I looked and again, 
/usr/bin did not appear to be there.  Just weird.

In response to


pgsql-cygwin by date

Next:From: Frank SeesinkDate: 2003-10-07 02:55:48
Subject: Re: "/usr/bin" supposed to exist?
Previous:From: Eddy CheeDate: 2003-10-06 15:13:46
Subject: installing on windows 2003

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group