|From:||Fabien COELHO <coelho(at)cri(dot)ensmp(dot)fr>|
|To:||Robert Haas <robertmhaas(at)gmail(dot)com>|
|Cc:||PostgreSQL Developers <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: extend pgbench expressions with functions|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
The v14 also remove references to the "threshold" word about gaussian and
exponential random generation in the source code (comments and variable
names), as it has no clear meaning, to replace it with param/parameter
depending on the context, as discussed in another thread started by Tomas
Sorry for the noise.
> Here is a v13 and a small test script.
> - change names to random(), random_exponential() and random_gaussian()
> I find them too long, but if the committer want that I cannot help
> - more comments, especially about the expression evaluation &
> type system.
> - improved documentation, in particular to include suggestions by Tomas
> Vondra about clarifying explanations about the gaussian &
> exponential random generators, and clear references from \setrandom
> to the \set expressions.
> - still just one patch, because removing double would mean removing the 2
> exponential & gaussian random functions which require a double
> Note that I started with one small patch for adding the infrastructure,
> but then Heikki requested more functions including double type stuff to
> illustrate the point, then Robert asks to break it back, going forward
> and backward is tiring...
> - still "lousy" *debug functions, because I found them useful for
> debugging and testing, really. It is easy to remove them, but I would
> advise against doing that as it would make debugging an expression
> much less straightforward.
|Next Message||Craig Ringer||2015-11-05 12:31:44||Re: Note about comparation PL/SQL packages and our schema/extensions|
|Previous Message||Haribabu Kommi||2015-11-05 11:20:19||Re: [PATCH] Skip ALTER x SET SCHEMA if the schema didn't change|