Re: [PoC] Improve dead tuple storage for lazy vacuum

From: John Naylor <john(dot)naylor(at)enterprisedb(dot)com>
To: Masahiko Sawada <sawada(dot)mshk(at)gmail(dot)com>
Cc: Nathan Bossart <nathandbossart(at)gmail(dot)com>, Andres Freund <andres(at)anarazel(dot)de>, Matthias van de Meent <boekewurm+postgres(at)gmail(dot)com>, Yura Sokolov <y(dot)sokolov(at)postgrespro(dot)ru>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: [PoC] Improve dead tuple storage for lazy vacuum
Date: 2022-12-23 11:47:08
Message-ID: CAFBsxsHdKnkSzyKwEgzL16-FQCEHuQ1jT5T6L=28DWT_sMfgPg@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-hackers

I wrote:

> - Try templating out the differences between local and shared memory.

Here is a brief progress report before Christmas vacation.

I thought the best way to approach this was to go "inside out", that is,
start with the modest goal of reducing duplicated code for v16.

0001-0005 are copies from v13.

0006 whacks around the rt_node_insert_inner function to reduce the "surface
area" as far as symbols and casts. This includes replacing the goto with an
extra "unlikely" branch.

0007 removes the STRICT pragma for one of our benchmark functions that
crept in somewhere -- it should use the default and not just return NULL
instantly.

0008 further whacks around the node-growing code in rt_node_insert_inner to
remove casts. When growing the size class within the same kind, we have no
need for a "new32" (etc) variable. Also, to keep from getting confused
about what an assert build verifies at the end, add a "newnode" variable
and assign it to "node" as soon as possible.

0009 uses the bitmap logic from 0004 for node256 also. There is no
performance reason for this, because there is no iteration needed, but it's
good for simplicity and consistency.

0010 and 0011 template a common implementation for both leaf and inner
nodes for searching and inserting.

0012: While at it, I couldn't resist using this technique to separate out
delete from search, which makes sense and might give a small performance
boost (at least on less capable hardware). I haven't got to the iteration
functions, but they should be straightforward.

There is more that could be done here, but I didn't want to get too ahead
of myself. For example, it's possible that struct members "children" and
"values" are names that don't need to be distinguished. Making them the
same would reduce code like

+#ifdef RT_NODE_LEVEL_LEAF
+ n32->values[insertpos] = value;
+#else
+ n32->children[insertpos] = child;
+#endif

...but there could be downsides and I don't want to distract from the goal
of dealing with shared memory.

The tests pass, but it's not impossible that there is a new bug somewhere.

--
John Naylor
EDB: http://www.enterprisedb.com

Attachment Content-Type Size
v16-0002-Move-some-bitmap-logic-out-of-bitmapset.c.patch text/x-patch 6.1 KB
v16-0001-introduce-vector8_min-and-vector8_highbit_mask.patch text/x-patch 2.6 KB
v16-0003-Add-radix-implementation.patch text/x-patch 90.8 KB
v16-0004-Use-bitmapword-for-node-125.patch text/x-patch 5.8 KB
v16-0005-tool-for-measuring-radix-tree-performance.patch text/x-patch 20.0 KB
v16-0009-Use-bitmap-operations-for-isset-arrays-rather-th.patch text/x-patch 6.4 KB
v16-0008-Use-newnode-variable-to-reduce-unnecessary-casti.patch text/x-patch 4.3 KB
v16-0010-Template-out-node-insert-functions.patch text/x-patch 17.6 KB
v16-0007-Remove-STRICT-from-bench_search_random_nodes.patch text/x-patch 863 bytes
v16-0011-Template-out-node-search-functions.patch text/x-patch 8.6 KB
v16-0012-Separate-find-and-delete-actions-into-separate-f.patch text/x-patch 9.9 KB
v16-0006-Preparatory-refactoring-to-simplify-templating.patch text/x-patch 5.8 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message David Rowley 2022-12-23 12:10:31 Re: Avoid lost result of recursion (src/backend/optimizer/util/inherit.c)
Previous Message Andres Freund 2022-12-23 11:27:08 Re: cirrus scripts could use make -k