Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal

From: Vladimir Rusinov <vrusinov(at)google(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: Stephen Frost <sfrost(at)snowman(dot)net>, Andres Freund <andres(at)anarazel(dot)de>, Michael Paquier <michael(dot)paquier(at)gmail(dot)com>, Jim Nasby <Jim(dot)Nasby(at)bluetreble(dot)com>, David Steele <david(at)pgmasters(dot)net>, Peter Eisentraut <peter(dot)eisentraut(at)2ndquadrant(dot)com>, Cynthia Shang <cynthia(dot)shang(at)crunchydata(dot)com>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal
Date: 2017-01-05 16:31:56
Message-ID: CAE1wr-xrMiP9-_78TodGXW1SuKL8cF0DdF7g_8antmc7z07YZA@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

Attaching a patch that renames all 'xlog' functions, keeping aliases for
old ones (since it looks like majority vote is for keeping them).

Following functions have been renamed:

Name | Replaced by
--------------------------------|-------------------------------
pg_current_xlog_flush_location | pg_current_wal_flush_location
pg_current_xlog_insert_location | pg_current_wal_insert_location
pg_current_xlog_location | pg_current_wal_location
pg_is_xlog_replay_paused | pg_is_recovery_paused
pg_last_xlog_receive_location | pg_last_wal_receive_location
pg_last_xlog_replay_location | pg_last_wal_replay_location
pg_switch_xlog | pg_switch_wal
pg_xlog_location_diff | pg_wal_location_diff
pg_xlog_replay_pause | pg_pause_recovery
pg_xlog_replay_resume | pg_resume_recovery
pg_xlogfile_name | pg_wal_file_name
pg_xlogfile_name_offset | pg_wal_file_name_offset

Questions/possible follow-up work:

- OIDs - where do I get numbers from? I was kinda choosing them at random,
unaware if there is some process for keeping track of them. Please point me
if such thing exists and I'll change them.
- Documentation. I've added a new section with a simple table, keeping it
somewhat neglected on purpose. We'll have old names in index and searchable
on page, but nothing more. Is it sufficient?
- New function names. I've used 'recovery' instead of 'xlog_replay' and
used 'wal_file' instead of 'xlogfile'. Does it make sense?
- Release notes. I was unable to find a draft for 10.0. How do I make sure
these renames are not forgotten?

--
Vladimir Rusinov
Storage SRE, Google Ireland

Google Ireland Ltd.,Gordon House, Barrow Street, Dublin 4, Ireland
Registered in Dublin, Ireland
Registration Number: 368047

Attachment Content-Type Size
0001-Remove-xlog-references-from-admin-functions.patch text/x-patch 74.1 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Stephen Frost 2017-01-05 16:37:25 Re: Replication/backup defaults
Previous Message Robert Haas 2017-01-05 16:27:56 Re: ALTER SYSTEM for pg_hba.conf