Re: increasing the default WAL segment size

From: Michael Paquier <michael(dot)paquier(at)gmail(dot)com>
To: Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: Andres Freund <andres(at)anarazel(dot)de>, Beena Emerson <memissemerson(at)gmail(dot)com>, Jim Nasby <Jim(dot)Nasby(at)bluetreble(dot)com>, "pgsql-hackers(at)postgresql(dot)org" <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: increasing the default WAL segment size
Date: 2017-01-27 23:04:52
Message-ID: CAB7nPqQ4hyNrLq+W1JrrYVSySOxuQa40PYb2Uw5UQkKaG4hong@mail.gmail.com
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

On Sat, Jan 28, 2017 at 7:29 AM, Robert Haas <robertmhaas(at)gmail(dot)com> wrote:
> On Thu, Jan 26, 2017 at 8:53 PM, Michael Paquier
> <michael(dot)paquier(at)gmail(dot)com> wrote:
>>> I've not done like the most careful review ever, but I'm in favor of the
>>> general change (provided the byval thing is fixed obviously).
>>
>> Thanks for the review.
>
> Why not use pg_ltoa and pg_lltoa like the output functions for the datatype do?

No particular reason.

> Might use CStringGetTextDatum(blah) instead of
> PointerGetDatum(cstring_to_text(blah)).

Yes, thanks.
--
Michael

Attachment Content-Type Size
refactor-repl-cmd-output-v3.patch application/octet-stream 11.8 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Peter Eisentraut 2017-01-27 23:05:03 Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal
Previous Message Peter Eisentraut 2017-01-27 23:03:34 Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal