Skip site navigation (1) Skip section navigation (2)

Re: 1.15 Dev with wxwidgets 2.9.3

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Colin Beckingham <colbec(at)start(dot)ca>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: 1.15 Dev with wxwidgets 2.9.3
Date: 2012-03-03 15:02:03
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgadmin-support
On Sat, Mar 3, 2012 at 1:54 PM, Colin Beckingham <colbec(at)start(dot)ca> wrote:
> Inspired by Guillaume's successful compile of the dev version with 2.9.x I
> felt adventurous and installed wxWidgets 2.9.3 (from source, no 2.9.x
> version available from opensuse yet) and tried to recompile pgadmin3, which
> failed:
> checking wxWidgets version... failed
> configure: error: The version of wxWidgets required (2.8) is not supported
> by the installations in /usr/local.
> Opensuse 12.1, pgadmin latest 1.15 dev from git.
> configure of wxwidgets with:
> ./configure --with-gtk --enable-gtk2 --enable-unicode
> make & make install apparently successful. Ran ldconfig. System reboot, no
> apparent issues.
> Ran make uninstall, make clean in wxwidgets, reinstalled wxwidgets-container
> + devel (2.8.x) with Yast, but configure problem in pgadmin persists.
> My current version of pgadmin3 previously compiled is still working, just
> cannot update.

Sounds like you didn't tell pgAdmin's configure script to use
wxWidgets 2.9, eg. ./configure --with-wx-version=2.9

If that's not it, please send the config.log file.

Dave Page
Twitter: @pgsnake

EnterpriseDB UK:
The Enterprise PostgreSQL Company

In response to


pgadmin-support by date

Next:From: Guillaume LelargeDate: 2012-03-03 15:36:28
Subject: Re: 1.15 Dev with wxwidgets 2.9.3
Previous:From: Colin BeckinghamDate: 2012-03-03 13:54:20
Subject: 1.15 Dev with wxwidgets 2.9.3

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group