Skip site navigation (1) Skip section navigation (2)

Re: pgAdmin III v1.10.2 released

From: Cedric Boudinet <cedric_boudinet(at)hotmail(dot)com>
To: <pgadmin-support(at)postgresql(dot)org>
Subject: Re: pgAdmin III v1.10.2 released
Date: 2010-03-18 12:31:01
Message-ID: BLU149-W64668D0DBAA46E19FA86CB802B0@phx.gbl (view raw, whole thread or download thread mbox)
Lists: pgadmin-support

It seems that PG minimal version may be set to 8.4.
I tried to built with 8.3 and I have an error with PQconninfoParse (from libpq-fe.h) which has been introduced with PG 8.4.

> Date: Thu, 18 Mar 2010 08:55:37 +0000
> Subject: Re: [pgadmin-support] pgAdmin III v1.10.2 released
> From: dpage(at)pgadmin(dot)org
> To: Dale(dot)J(dot)Thompson(at)noaa(dot)gov
> CC: pgadmin-support(at)postgresql(dot)org
> On Wed, Mar 17, 2010 at 5:46 PM, Dale J Thompson
> <Dale(dot)J(dot)Thompson(at)noaa(dot)gov> wrote:
> > I apologize for assuming this was a well known problem.
> >
> > If it's not feasible to adjust the build to work around this issue, I'd
> > suggest the documentation for pgAdmin be updated to clarify that it requires
> > 8.3(?) or greater version of postgresql to build. It's certainly not
> > reasonable to assume people will be willing to remove their vendor provided
> > and supported versions of postgresql, but this documentation update would
> > help people to know they need to build a 1.10.0 version if they use Redhat
> > 5. That's the rpm I build for my userbase and it mostly works fine.
> Oh, sorry - my comments were aimed at the other devs. They probably
> seemed a bit harsh from your perspective.
> The problem is that but restricting ourselves to support of older
> versions of libpq, we either lose out on important functionality for
> may years, or we have to build pgAdmin in such a way that features get
> enabled or disabled based on the version of libpq in use, which leads
> to an inconsistent experience that many users won't understand, and
> makes it harder to debug problems that crop up.
> Limiting ourselves to a modern libpq shouldn't be an issue for a
> number of reasons:
> - it's versioned, so updating it on a machine should not be an issue
> if an older version is already installed.
> - most users that want a modern pgAdmin will probably use a package
> repository that offers them that and also the newer PostgreSQL.
> - In the worst case scenario, users can always statically link with a
> private copy of the newer version, or install into a private directory
> and include the newer libpq there.
> The docs were out of date though - I've fixed that now.
> > By the way, my users where specifically looking for the graphical query
> > builder, which was my reason for looking into version 1.10.x of pgAdmin.
> It might be slightly more of a pain to build/distribute if you have
> vendor packages for 8.1 installed that you do not wish to touch, but
> it shouldn't be an insurmountable problem.
> -- 
> Dave Page
> EnterpriseDB UK:
> PG East Conference:
> -- 
> Sent via pgadmin-support mailing list (pgadmin-support(at)postgresql(dot)org)
> To make changes to your subscription:
Obtenez la version mobile de Messenger ici

In response to


pgadmin-support by date

Next:From: Vinicius BorgesDate: 2010-03-18 12:34:10
Subject: Re: Problem with in pgadmin3-1.10.2
Previous:From: Vinicius BorgesDate: 2010-03-18 12:13:24
Subject: Re: Problem with in pgadmin3-1.10.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group