On Fri, Apr 1, 2011 at 11:45 AM, David E. Wheeler <david(at)kineticode(dot)com> wrote:
> But I'm assuming that at some point there's going to be something a bit more robust: specifically, requiring a minimum version, perhaps something like:
> requires = 'foo 1.0, bar 0.31.4'
requires = 'foo = 1.0, bar >= 0.31.4'
> * I think we're going to need a formal version string spec for extensions.
> * If that's true, I think it should be specified *now*, before extensions are in the wild, so that we don't end up with the legacy version string nightmares that Perl modules suffer from.
I think I agree with this, too.
> * If we do adopt a spec, I think it should reflect the PostgreSQL core version strings as closely as possible, and should be fully compatible with them.
I am less sure about this one.
> * So it might be worth looking at semver or something similar to integrate.
No. It's too late to be monkeying with this. I think for 9.1 we will
need to content ourselves with setting a good precedent, rather than
enforcing it programatically. It's not going to work to insist on all
numeric version strings anyway, because we've already got this 'FROM
unpackaged' bit floating around.
The Enterprise PostgreSQL Company
In response to
pgsql-hackers by date
|Next:||From: Tom Lane||Date: 2011-04-04 21:48:34|
|Subject: Re: Extensions Dependency Checking |
|Previous:||From: Robert Haas||Date: 2011-04-04 21:22:33|
|Subject: Re: GUC assign hooks (was Re: wal_buffers = -1 and SIGHUP)|