Re: New GUC to sample log queries

From: Adrien Nayrat <adrien(dot)nayrat(at)anayrat(dot)info>
To: Vik Fearing <vik(dot)fearing(at)2ndquadrant(dot)com>, Michael Paquier <michael(at)paquier(dot)xyz>
Cc: David Rowley <david(dot)rowley(at)2ndquadrant(dot)com>, PostgreSQL mailing lists <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: New GUC to sample log queries
Date: 2018-07-10 18:34:15
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

On 06/27/2018 11:13 PM, Adrien Nayrat wrote:
>> 3) Is it intentional to only sample with log_min_duration_statement and
>> not also with log_duration? It seems like it should affect both. In
>> both cases, the name is too generic. Something called "log_sample_rate"
>> should sample **everything**.
> I do not think it could be useful to sample other case such as log_duration.
> But yes, the GUC is confusing and I am not comfortable to introduce a new GUC in
> my initial patch.
> Maybe we should adapt current GUC with something like :
> log_min_duration_statement = <time>,<sample rate>>
> This give :
> log_min_duration_statement = 0,0.1
> Equivalent to :
> log_min_duration_statement = 0
> log_sample_rate = 0.1
> Thought?

After reflection it seems a bad idea :

* it breaks compatibility with external tools
* it introduce a kind of "composite" GUC which may add complexity to use. For
example in pg_settings view.

What do you think of : log_min_duration_statement_sample ? Is it too long?

I saw a few days ago this error on

postgres.sgml:5202: element xref: validity error : IDREF attribute linkend
references an unknown ID "log_min_duration_statement"

Patch attached with fix on linkend marker



Attachment Content-Type Size
sample_rate-4.patch text/x-patch 4.4 KB

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Justin Pryzby 2018-07-10 18:38:28 Re: performance statistics monitoring without spamming logs
Previous Message Tom Lane 2018-07-10 18:30:47 Re: no partition pruning when partitioning using array type