|From:||Antonin Houska <ah(at)cybertec(dot)at>|
|To:||Alvaro Herrera <alvherre(at)2ndquadrant(dot)com>|
|Subject:||Re: Attempt to consolidate reading of XLOG page|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
Antonin Houska <ah(at)cybertec(dot)at> wrote:
> Alvaro Herrera <alvherre(at)2ndquadrant(dot)com> wrote:
> > Not sure about the walsize; maybe it can be a member in XLogReadPos, and
> > given to XLogReadInitPos()? (Maybe rename XLogReadPos as
> > XLogReadContext or something like that, indicating it's not just the
> > read position.)
> As pointed out by others, XLogReadPos is not necessary. So if XLogRead()
> receives XLogReaderState instead, it can get the segment size from there.
Eventually I found out that it's good to have a separate structure for the
read position because walsender calls the XLogRead() function directly, not
via the XLOG reader. Currently the structure name is XLogSegment (maybe
someone can propose better name) and it's a member of XLogReaderState. No
field of the new structure is duplicated now.
The next version of the patch is attached.
|Next Message||Jeff Janes||2019-05-02 16:24:17||Re: pg_upgrade --clone error checking|
|Previous Message||Alvaro Herrera||2019-05-02 16:03:35||Re: New vacuum option to do only freezing|