Skip site navigation (1) Skip section navigation (2)

Re: latest hstore patch

From: Andrew Gierth <andrew(at)tao11(dot)riddles(dot)org(dot)uk>
To: tgl(at)sss(dot)pgh(dot)pa(dot)us (Tom Lane), david(at)kineticode(dot)com ("David E(dot) Wheeler"), pgsql-hackers(at)postgresql(dot)org
Subject: Re: latest hstore patch
Date: 2009-09-29 23:11:53
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers
>>>>> "Tom" == Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> writes:

 David> * More name stuff: Why `hstore_to_list` rather than
 David> `hstore_to_array`?  And I'm not sure about `hstore_to_matrix`
 David> for the 2-dimensional array.  I guess that's better than
 David> `hstore_to_multidimensional_array` would be. ;-)

 >> I intentionally avoided hstore_to_array because it would be
 >> unclear which one it meant (the 1-d or 2-d result).

 Tom> hstore_to_list seems like a pretty horrible name though for
 Tom> something that produces an array.  I also note that "array"
 Tom> means "1-D array" according to no less an authority than the SQL
 Tom> standard ;-).  I think we could live with hstore_to_array and
 Tom> hstore_to_matrix.  Thoughts, other ideas?

I don't feel particularly strongly about the name (I've also
intentionally held off on updating the pgfoundry version of the code
until this is settled so no-one else should care either).

My own expectation is that the operator should normally be used in
preference (though obviously people's tastes will vary in this

Andrew (irc:RhodiumToad)

In response to


pgsql-hackers by date

Next:From: Josh BerkusDate: 2009-09-29 23:22:33
Subject: Re: latest hstore patch
Previous:From: Tom LaneDate: 2009-09-29 22:56:02
Subject: Re: latest hstore patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group