On Tue, Jan 26, 2010 at 1:38 PM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> Robert Haas <robertmhaas(at)gmail(dot)com> writes:
>> On Tue, Jan 26, 2010 at 12:36 PM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>>> But what it *produces* is a string. For comparison, the
>>> SQL-standard-specified array_agg produces arrays, but what it
>>> acts on isn't an array.
>> This point is well-taken, but naming it string_agg() because it
>> produces a string doesn't seem quite descriptive enough. We might
>> someday (if we don't already) have a number of aggregates that produce
>> an output that is a string; we can't name them all by the output type.
> True, but the same point could be made against array_agg, and that
> didn't stop the committee from choosing that name. As long as
> string_agg is the "most obvious" aggregate-to-string functionality,
> which ISTM it is, I think it's all right for it to have pride of place
> in naming.
Maybe so, but personally, I'd still prefer something more descriptive.
In response to
pgsql-hackers by date
|Next:||From: David Fetter||Date: 2010-01-27 22:10:01|
|Subject: Re: make everything target|
|Previous:||From: Robert Haas||Date: 2010-01-27 21:58:35|
|Subject: Re: [BUG?] strange behavior in ALTER TABLE ... RENAME TO on inherited columns|