Skip site navigation (1) Skip section navigation (2)

Re: per-tablespace random_page_cost/seq_page_cost

From: Robert Haas <robertmhaas(at)gmail(dot)com>
To: Alvaro Herrera <alvherre(at)commandprompt(dot)com>
Cc: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Andres Freund <andres(at)anarazel(dot)de>, pgsql-hackers(at)postgresql(dot)org, Greg Stark <gsstark(at)mit(dot)edu>, Josh Berkus <josh(at)agliodbs(dot)com>
Subject: Re: per-tablespace random_page_cost/seq_page_cost
Date: 2009-11-03 12:49:34
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers
On Tue, Nov 3, 2009 at 6:25 AM, Alvaro Herrera
<alvherre(at)commandprompt(dot)com> wrote:
>> > If this is the case, then I think we could just decide that their name
>> > is reloptions due to hysterical reasons and be done with it.
>> Yeah.  It's particularly unfortunate that we call them "reloptions" in
>> the code but "storage parameters" in the documentation.  Neither is a
>> particularly good name, and having two different ones is extra-poor.
>> But I'm fine with leaving the names as they are and moving on, if no
>> one objects too much.  Speak now or don't complain about it after I
>> write the patch!
> Maybe after we move to Git we can rename them in the code?

I'm OK with renaming it before I start working on the main patch, or
after it's committed, or never.  I just don't want to have to rebase
it in the middle.


In response to


pgsql-hackers by date

Next:From: Alvaro HerreraDate: 2009-11-03 12:51:52
Subject: Re: per-tablespace random_page_cost/seq_page_cost
Previous:From: Dimitri FontaineDate: 2009-11-03 12:44:57
Subject: Re: per-tablespace random_page_cost/seq_page_cost

Privacy Policy | About PostgreSQL
Copyright © 1996-2018 The PostgreSQL Global Development Group