|From:||Etsuro Fujita <fujita(dot)etsuro(at)lab(dot)ntt(dot)co(dot)jp>|
|To:||Robert Haas <robertmhaas(at)gmail(dot)com>|
|Cc:||Rushabh Lathia <rushabh(dot)lathia(at)gmail(dot)com>, Thom Brown <thom(at)linux(dot)com>, Stephen Frost <sfrost(at)snowman(dot)net>, Albe Laurenz <laurenz(dot)albe(at)wien(dot)gv(dot)at>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Shigeru Hanada <shigeru(dot)hanada(at)gmail(dot)com>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>|
|Subject:||Re: Optimization for updating foreign tables in Postgres FDW|
|Views:||Raw Message | Whole Thread | Download mbox|
On 2016/03/10 2:56, Robert Haas wrote:
> I see that you went and changed all of the places that tested for !=
> CMD_SELECT and made them test for == CMD_INSERT || == CMD_UPDATE || ==
> CMD_DELETE instead. I think that's the wrong direction. I think that
> we should use the != CMD_SELECT version of the test everywhere.
> That's a single test instead of three, so marginally faster, and maybe
> marginally more future-proof.
> I think deparsePushedDownUpdateSql should be renamed to use the new
> "direct modify" naming, like deparseDirectUpdateSql, maybe.
> I would suggest not numbering the tests in postgresPlanDirectModify.
> That just becomes a nuisance to keep up to date as things change.
Agreed. I updated the patch to address these comments. Attached is the
updated version of the patch.
|Next Message||Robert Haas||2016-03-18 09:52:22||Re: Performance degradation in commit ac1d794|
|Previous Message||Dilip Kumar||2016-03-18 09:08:18||Re: Relation extension scalability|