Re: Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map

From: Adrian Klaver <adrian(dot)klaver(at)aklaver(dot)com>
To: Sribeiro <info(at)simetriastudio(dot)com>, pgsql-sql(at)postgresql(dot)org
Subject: Re: Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map
Date: 2015-12-03 16:48:53
Message-ID: 56607275.4060404@aklaver.com
Views: Whole Thread | Raw Message | Download mbox | Resend email
Thread:
Lists: pgsql-sql

On 12/03/2015 08:33 AM, Sribeiro wrote:
> 1) yes, I have a fresh install from yesterday in the /usr/local/var/postgres
> directory. Yesterday there was no server.log in that directory, but today I
> have a server.log in that directory. There's only one timestamp:
> /LOG: database system was shut down at 2015-12-02 16:33:52 EST
> LOG: MultiXact member wraparound protections are now enabled
> LOG: autovacuum launcher started
> LOG: database system is ready to accept connections/
>
> 2) Yes, but only one server.log file with many entries/timestamps that
> includes the timestamp mentioned previously.
>
> 3) Here is the path to the directory where the older server.log resides -
> /Users/Serge/Desktop/postgres
>
> 4) Both installs have the pg_filenode.map inside the global directory, but

How can that be?

From previous posts:
"

Dec 02, 2015; 1:06pm Sribeiro Sribeiro
This is what that directory looks like - http://postimg.org/image/olhb2zra9/

I can't find anywhere on my system (doing a search) the .map file.

Thank you for clarifying the importance of that file.
Since I didn't have any important information on it, can I start from
scratch, and thus creating a new .map file?

Sergio

Dec 02, 2015; 1:44pm Sribeiro Sribeiro
This post was updated on Dec 02, 2015; 1:45pm.
Hi Adrian,

So, i made sure to copy the postgres directory then deleted the main one
as to not conflict with a fresh install.

Once I got to the section in the instructions I used that says to run
the - rake db:create:all
I get the following error:
rake db:create:all
FATAL: could not open relation mapping file "global/pg_filenode.map":
No such file or directory

BUT, if I look in the newest postgres/global directory, the
pg_filenode.map is in there.

Any thoughts

Sergio
"

Are you sure /Users/Serge/Desktop/postgres is not a link to somewhere?

> when I ran the commands from yesterday, I kept getting the error message:
> /psql: FATAL: could not open relation mapping file
> "global/pg_filenode.map": No such file or directory /

Have you tried stopping Postgres and then restarting it?

>
>
>
> --
> View this message in context: http://postgresql.nabble.com/ERROR-while-creating-new-user-could-not-open-relation-mapping-file-global-pg-filenode-map-tp5874842p5876161.html
> Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>

--
Adrian Klaver
adrian(dot)klaver(at)aklaver(dot)com

In response to

Responses

Browse pgsql-sql by date

  From Date Subject
Next Message Sribeiro 2015-12-03 18:29:21 Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map
Previous Message Sribeiro 2015-12-03 16:33:38 Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map