Re: Perl coding error in msvc build system?

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Cc: Robert Haas <robertmhaas(at)gmail(dot)com>, Brar Piening <brar(at)gmx(dot)de>, Abhijit Menon-Sen <ams(at)2ndquadrant(dot)com>
Subject: Re: Perl coding error in msvc build system?
Date: 2015-02-16 21:34:07
Message-ID: 54E2624F.6030805@gmx.net
Views: Raw Message | Whole Thread | Download mbox
Thread:
Lists: pgsql-hackers

> This patch been reviewed by 4 people, resulting in 2 minor suggestions
> for changes (adding an m modifier, and removing a bogus last).
>
> It has 2 clear upvotes and 0 downvotes.
>
> I think it should be revised along the lines suggested and committed
> without further ado.

My patch actually only covered the first of the two faulty locations I
pointed out. Attached is a patch that also fixes the second one. I
noticed that DetermineVisualStudioVersion() is never called with an
argument, so I removed that branch altogether.

Attachment Content-Type Size
msvc-open-pipe-v2.patch text/x-patch 2.0 KB

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Bruce Momjian 2015-02-16 21:35:46 Re: Allow "snapshot too old" error, to prevent bloat
Previous Message Michael Paquier 2015-02-16 20:51:22 Expanding the use of FLEXIBLE_ARRAY_MEMBER for declarations like foo[1]