Skip site navigation (1) Skip section navigation (2)

Re: wCTE: about the name of the feature

From: Marko Tiikkaja <marko(dot)tiikkaja(at)cs(dot)helsinki(dot)fi>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: wCTE: about the name of the feature
Date: 2011-02-24 16:33:08
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers
On 2011-02-24 6:20 PM +0200, Tom Lane wrote:
> The wCTE patch refers to the feature it's adding as "DML WITH".  I'm
> still pretty unhappy with that terminology.  In my view of the world,
> "DML" includes SELECT as well as INSERT/UPDATE/DELETE.  The wikipedia
> entry about the term
> agrees that that's at least the majority usage, and even our own docs
> seem to use it to include SELECT as often as not.  Since the distinction
> is absolutely critical to talking about this feature sensibly, I don't
> think it's a good plan to use an acronym that is guaranteed to produce
> uncertainty in the reader's mind.


> The best idea I have at the moment is to spell out "data modifying
> command" (or "statement") rather than relying on the acronym.
> In the code, we could change hasDmlWith to hasModifyingWith, for
> example.  The error messages could read like
> 	data-modifying statement in WITH is not allowed in a view
> Comments?

Out of everything suggested so far, I think this is the best we have, if 
we can fit the whole thing into out error messages.  Quickly grepping 
through the patch suggests that we can, at least for the cases in the 
current patch.

I also prefer "statement" over "command".

Marko Tiikkaja

In response to


pgsql-hackers by date

Next:From: Florian PflugDate: 2011-02-24 16:36:39
Subject: Re: Possible substitute for PostmasterIsAlive polling loops
Previous:From: Tom LaneDate: 2011-02-24 16:20:48
Subject: wCTE: about the name of the feature

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group