Skip site navigation (1) Skip section navigation (2)

Re: Command to prune archive at restartpoints

From: Andrew Dunstan <andrew(at)dunslane(dot)net>
To: Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: Greg Stark <gsstark(at)mit(dot)edu>, Simon Riggs <simon(at)2ndquadrant(dot)com>, Heikki Linnakangas <heikki(dot)linnakangas(at)enterprisedb(dot)com>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Command to prune archive at restartpoints
Date: 2010-06-08 22:30:38
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers

Robert Haas wrote:
> On Mon, Mar 22, 2010 at 11:58 AM, Greg Stark <gsstark(at)mit(dot)edu> wrote:
>> On Thu, Mar 18, 2010 at 9:43 AM, Simon Riggs <simon(at)2ndquadrant(dot)com> wrote:
>>> On Wed, 2010-03-17 at 11:37 +0200, Heikki Linnakangas wrote:
>>>> One awkward omission in the new built-in standby mode, mainly used for
>>>> streaming replication, is that there is no easy way to delete old
>>>> archived files like you do with the %r parameter to restore_command.
>>> Would it be better to call this "archive_cleanup_command"? That might
>>> help people understand the need for and the use of this parameter.
>> This is bikeshedding but fwiw I like Simon's suggestion.
> So, this thread is hanging out on our list of open items for 9.0.  My
> personal opinion on it is that I don't really care much one way or the
> other.  archive_cleanup_command does seem easier to understand, but
> restartpoint_command has the advantage of describing exactly when it
> gets run from a technical perspective, which might be a good thing,
> too.  Since nobody's felt motivated to do anything about this for two
> and a half months and we've now been through two betas with it the way
> it is, I'm inclined to say we should just leave it alone.  On the
> other hand, both of the people who voted in favor of changing it are
> committers, and if one of them feels like putting in the effort to
> change it, it won't bother me much, except that I feel it should get
> done RSN.  But one way or the other we need to make a decision and get
> this off the list.

I prefer archive_cleanup_command. We should name things after their 
principal function, not an implementation detail, IMNSHO.

More importantly, we should include an example in the docs. I created 
one the other day  when this was actually bothering me a bit (see 
That seemed to work ok, but maybe it's too long, and maybe people would 
prefer a shell script to perl.



In response to


pgsql-hackers by date

Next:From: Andrew DunstanDate: 2010-06-08 22:33:01
Subject: Re: hot_standby = on
Previous:From: Josh BerkusDate: 2010-06-08 22:20:12
Subject: Re: How about closing some Open Items?

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group