I wrote:> Andres Freund <andres(at)anarazel(dot)de> writes:>> Only PM_CHILD_ACTIVE and PM_CHILD_WALSENDER though. We could afford another>> MaxLivePostmasterChildren() sized array...
> Oh, I see what you mean --- one private and one public array.> Maybe that makes more sense than what I did, not sure.
Yeah, that's definitely a better way. I'll push this after therelease freeze lifts.
regards, tom lane