Skip site navigation (1) Skip section navigation (2)

Re: get the copy of a schema

From: vaniShree <shreevani04(at)gmail(dot)com>
To: pgadmin-support(at)postgresql(dot)org
Subject: Re: get the copy of a schema
Date: 2009-11-25 15:59:24
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgadmin-support
Hi ,
The Pg_dump is installed in c:\pgsql\bin.And I tried with Setting pgbin path
as c:\pgsql\bin.
It dint work.
The version of the pg_dump is

c:\pgsql\bin>pg_dump --version
      pg_dump <POstgresSQL> 8.4.1

I tried the psql select version();

   i got this  "EnterpriseDB on i686-pc-mingw32, compiled by GCC
gcc.exe (GCC) 3.4.5 (mingw-vista special r3)"


Raymond O'Donnell wrote:
> On 25/11/2009 14:30, vaniShree wrote:
>>  I installed pg_dump.exe.It is installed in the c:\pgsql\.And i have set
>> the
>> pg bin path as c:\pgsql\bin in pgAdmin.I tried with setting path as
>> c:\pgsql\bin\pg_dump.exe.
> Hi Vani,
> You don't need to include pg_dump itself, just the directory path. For
> example, my pg_dump.exe is here -
>   C:\Program Files\PostgreSQL\8.4\bin\pg_dump.exe
> and so I have set the PG bin path as:
>   C:\Program Files\PostgreSQL\8.4\bin
>> It  gives an 
>> Error: PostgresSQL bin path specified is not valid or does not contain a
>> postgres SQl pg_dump executable.
> Hmmm... Are you sure that pg_dump is where you're saying it is, in
> c:\pgsql\bin? You said above that it's in c:\pgsql.
>> I have tried  Another option  from the command line.
>> I tried this from  c:\pgsql\bin
>> 1.   pg_dump  -h  192.678.1.67 –p  5436 –U postgres  unique_manage
>> >data.sql
>> The Error I am getting is 
>>   Pg_dump: SQL command failed 
>>    Pg_dump:Error Message from server:Error:unrecognized configuration
>> parameter “synchronize_seqscans”
>>  Pg_dump :The command was:SET synchronize_seqscans TO off
> I'm afraid I don't know what that means. What version of pg_dump do you
> have, and what version of the PostgreSQL server? - For pg_dump, execute:
>    pg_dump --version
> And for the server, connect to it with psql and execute:
>    select version();
> I'm wondering if there's a version mismatch.
> I'm away for a few days from this evening, so hopefully others will be
> able to help you.
> Ray.
> -- 
> Raymond O'Donnell :: Galway :: Ireland
> rod(at)iol(dot)ie
> -- 
> Sent via pgadmin-support mailing list (pgadmin-support(at)postgresql(dot)org)
> To make changes to your subscription:

View this message in context:
Sent from the PostgreSQL - pgadmin support mailing list archive at

In response to


pgadmin-support by date

Next:From: Dave PageDate: 2009-11-26 12:08:30
Subject: Re: Bug report: pgadmin3-1.10.0 segmentation fault
Previous:From: Raymond O'DonnellDate: 2009-11-25 15:19:50
Subject: Re: get the copy of a schema

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group