Skip site navigation (1) Skip section navigation (2)

Re: Review: listagg aggregate

From: Alastair Turner <bell(at)ctrlf5(dot)co(dot)za>
To: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
Cc: "pgsql-hackers(at)postgresql(dot)org Hackers" <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Review: listagg aggregate
Date: 2010-01-26 11:44:34
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers
On Tue, Jan 26, 2010 at 1:23 PM, Alastair Turner <bell(at)ctrlf5(dot)co(dot)za> wrote:
> .....
> Given that it potentially produces a delimited list, not a straight
> conacatenation (and that list is unacceptable since it would be
> descriptive as a noun but not as a verb) would implode_agg not be the
> most descriptive name?

Actually, scratch that. The other *agg functions are named for what
they produce as output. Not for their process - as per the objection
to list_agg and suggestions of conact_agg and implode_agg. string_agg
would be consistent, which is a wonderful thing if you can get it in a
naming scheme.

In response to

pgsql-hackers by date

Next:From: Heikki LinnakangasDate: 2010-01-26 11:54:30
Subject: Re: Dividing progress/debug information in pg_standby, and stat before copy
Previous:From: Alastair TurnerDate: 2010-01-26 11:23:58
Subject: Re: Review: listagg aggregate

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group