Re: recovery modules

From: Nathan Bossart <nathandbossart(at)gmail(dot)com>
To: Michael Paquier <michael(at)paquier(dot)xyz>
Cc: Andres Freund <andres(at)anarazel(dot)de>, pgsql-hackers(at)postgresql(dot)org
Subject: Re: recovery modules
Date: 2023-01-12 18:17:21
Message-ID: 20230112181721.GA2103226@nathanxps13
Views: Raw Message | Whole Thread | Download mbox | Resend email
Lists: pgsql-hackers

On Thu, Jan 12, 2023 at 03:30:40PM +0900, Michael Paquier wrote:
> On Wed, Jan 11, 2023 at 11:29:01AM -0800, Nathan Bossart wrote:
>> I initially created a separate basic_restore module, but decided to fold it
>> into basic_archive to simplify the patch and tests. I hesitated to rename
>> it because it already exists in v15, and since it deals with creating and
>> restoring archive files, the name still seemed somewhat accurate. That
>> being said, I don't mind renaming it if that's what folks want.
> I've done that in the past for pg_verify_checksums -> pg_checksums, so
> I would not mind renaming it so as it reflects better its role.
> (Being outvoted is fine for me if this suggestion sounds bad).

IMHO I don't think there's an urgent need to rename it, but if there's a
better name that people like, I'm happy to do so.

> Saying that, 0001 seems fine on its own (minus the redo LSN/TLI with
> the duplication for the segment name build), so I would be tempted to
> get this one done. My gut tells me that we'd better remove the
> duplication and just pass down the two fields to
> shell_archive_cleanup() and shell_recovery_end(), with the segment
> name given to ExecuteRecoveryCommand()..

I moved the duplicated logic to its own function in v6.

Nathan Bossart
Amazon Web Services:

Attachment Content-Type Size
v6-0001-Move-the-code-to-restore-files-via-the-shell-to-a.patch text/x-diff 16.0 KB
v6-0002-Refactor-code-for-restoring-files-via-shell.patch text/x-diff 5.8 KB
v6-0003-Allow-recovery-via-loadable-modules.patch text/x-diff 51.6 KB

In response to


Browse pgsql-hackers by date

  From Date Subject
Next Message Andres Freund 2023-01-12 18:24:34 Re: Generate pg_stat_get_xact*() functions with Macros
Previous Message Andres Freund 2023-01-12 18:16:30 Re: Minimal logical decoding on standbys